
During	our	program	this	month	we	plan	to	discuss		
•	Apple	devices	that	turn	off	unexpectedly.	(It	has	been	known	to	happen.)	

•	New	iPhones	and	using	iPhones	for	scanning	

•	Photomyne,	an	app	for	using	your	iPhone	or	iPad	for	scanning.	See	https://
www.youtube.com/photomyne	for	an	introduction	to	the	app.
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Keystone MacCentral is a not-for-profit group of Macintosh enthusiasts who  
generally meet the third Tuesday of every month to exchange information,  
participate in question-and-answer sessions, view product demonstrations, and 
obtain resource materials that will help them get the most out of their computer  
systems. Meetings are free and open to the public. The Keystone MacCentral 
printout is the official newsletter of Keystone MacCentral and an independent 
publication not affiliated or otherwise associated with or sponsored or sanctioned by 
any for-profit organization, including Apple Inc. Copyright © 2023, Keystone 
MacCentral, 310 Somerset Drive, Shiresmanstown, PA 17011.  

Nonprofit user groups may reproduce articles form the Printout only if the 
copyright notice is included, the articles have not been edited, are clearly  
attributed to the original author and to the Keystone MacCentral Printout, and  
a copy of the publication is mailed to the editor of this newsletter. 

The opinions, statements, positions, and views stated herein are those of the  
author(s) or publisher and are not intended to be the opinions, statements,  
positions, or views of Apple, Inc. 

Throughout this publication, trademarked names are used. Rather than include a 
trademark symbol in every occurrence of a trademarked name, we are using the 
trademarked names only for editorial purposes and to the benefit of the  
trademark owner with no intent of trademark infringement.
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On the Web, tables are everywhere—you may 
not even realize how many sites rely on 

tables behind the scenes for their formatting. Useful 
as they are for aligning content and displaying 
columnar data, tables can cause significant 
frustration if you need to extract data from them. I 
find myself wanting to do this quite often now that 
I have the open-source Copytables. I use the free 
Copytables Chrome extension in Arc, Brave, and 
Google Chrome, but you can also download 
Copytables for Firefox (forked from the Chrome 
version) and Copytables for Safari ($2.99 on the 
Mac App Store). I haven’t tested those.

Here’s an example of what Copytables makes 
possible. Earlier this week, I wanted to email 
someone a list of opportunities from the volunteer-
management tool Helper Helper. To extract the text 
from the table in the Web app’s interface without 
Copytables, I would have to select the entire table 
(below left), copy it, and paste it into BBEdit (below 
right). The results in BBEdit aren’t terrible 
compared to some tables I’ve seen, but I’d still need 
to delete every other line. That would be doable 
with such a small table, but what if there were 
hundreds of lines or the data didn’t break cleanly at 
line breaks?

With Copytables in Arc, I instead pressed the 
Option key to enter cell-selecting mode and 
dragged over the cells in the leftmost column to 
select just them (below left). When I copied and 

pasted into BBEdit, I got exactly what I wanted 
(below right).

Another example. I’ve been in a pitched battle with 
spambots for the last few weeks, and one of my 
most successful interim defenses has been blocking 
IP ranges. Using Copytables, I can extract hundreds 
of IP addresses quickly from the logs of our 
WordPress security plug-ins. To select the contents 
of a column, I press Command-Option and click the 
column header. Then it’s trivial to copy the data 
into BBEdit for manipulation. You can even make 
discontinuous selections—cells that aren’t next to 
each other.

Copytables also enables you to select rows or entire 
tables. Those features aren’t as commonly used—
they don’t even get default keyboard shortcuts—so 
whenever I need them, I open the Copytables 
window (from the Extensions menu in Arc, or by 
clicking a pinned extension toolbar icon in Brave or 

By Adam Engst

Copytables Simplifies  
Extracting Tabular Data  

from Web Pages

https://merribithouse.net/copytables/
https://chrome.google.com/webstore/detail/copytables/ekdpkppgmlalfkphpibadldikjimijon
https://addons.mozilla.org/en-US/firefox/addon/copywebtables/
https://merribithouse.net/copytables/safari/
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Google Chrome), click Rows or Tables to enable the 
associated capture mode, and then click to select. If 
you do use the Capture buttons, make sure to 
disable them when you’re done, or certain Web 
apps won’t work correctly due to Copytables 
capturing their clicks. To select entire tables more 
quickly, click the Previous Table or Next Table 
buttons in the Find row. 

The Copy options at the top require more 
explanation. I haven’t needed them, but they offer 
various formats for the copied data, some of which 
could be handy (I’m particularly taken with the 
options that swap columns and rows). 
Theoretically, you can set one of these options as 
the default to use with Edit > Copy, but that didn’t 
work in my quick testing. Stick to the buttons in the 
Copytables interface.

•As is: Copy the table as seen on the screen
• Plain Table: Copy the table without formatting
•Text: Copy as tab-delimited text
•Text+Swap: Copy as tab-delimited text, swap 

columns and rows
•CSV: Copy as comma-separated text
•CSV+Swap: Copy as comma-separated text, swap 

columns and rows
•HTML+CSS: Copy as HTML source with 

formatting
•HTML: Copy as HTML source without formatting

•Textile: Copy as Textile (text content)
•Textile+HTML: Copy as Textile (HTML content)

Copytables has one other clever feature I 
occasionally find handy: the infobox. It’s an inset 
box that shows information about your current 
selection. Consider this table of data about 
Canadian wildfires from 2000–2021. When I select 
the contents of the Area Burned column, 
Copytables displays the blue infobox at the top that 
counts the number of selected cells, calculates the 
sum and average, and calls out the min and max. 
These simple calculations can preclude the need to 
move data to a spreadsheet.

If the infobox gets in your way, you can turn it off 
or have Copytables display it in a different corner 
of the window. To access this and other settings, 
click the Options link in the Copytables window. 
The most useful settings are the modifier keys for 
click-and-drag selection (below). You’ll want to 
adjust these if they conflict with something else on 
your system. The Copytables window also has a 
Keyboard Shortcuts link that provides a browser-
wide approach to setting keyboard shortcuts for 
extensions; the Copytables options match the Find 
and Capture buttons in its window.

Copytables is free, but if you find it useful, you can 
join me in donating to the author, Georg Barikin.

https://en.wikipedia.org/wiki/Textile_(markup_language)
https://merribithouse.net/copytables/


Page 5

The first two Do You Use It? polls revolved 
around features that are easy to use or 

ignore: Stage Manager and Launchpad. The story is 
much more complex with Spotlight, the focus of 
our third poll. Apple introduced Spotlight in 2005 
with Mac OS X 10.4 Tiger, making it a fixture on the 
Mac for 18 years. Over that time, Apple has 
continually added features beyond searching for 
files on the local drive. Its capabilities have 
garnered widespread use among TidBITS readers, 
with 85% of respondents to our poll saying that 
they used it at least occasionally. The blue bar in the 
chart below indicates my vote—although I employ 
Spotlight for various tasks, they don’t crop up 
every day.

Notably, 43% of respondents use Spotlight daily, 
but what they use it for varies widely. That’s 
unsurprising, given all that Spotlight can do, so the 
poll posed a second question to tease out 
Spotlight’s most popular features, as you can see 
below. Note that the poll explicitly asked about the 
standalone Spotlight interface, not uses of the 
Spotlight database within other apps, like the 
Finder, Mail, and Messages. (Again, blue bars 
indicate my responses.)

Spotlight’s features fall into three basic categories: 
searching, navigating, and utilities.

• Searching: As befitting its original purpose, the 
most-used Spotlight feature was finding files, with 
78% of responses. Beyond basic searching, 
however, usage dropped off quickly, with only 
30% of respondents using Spotlight to search 
within Mail and Messages, 24% using it to find 
contacts, 16% using it to search for images locally 
or online, and 15% using it to find Web content. 

By Adam Engst

Do You Use It?  
Spotlight Sees Targeted Use for  

Finding Files and Launching Apps

https://support.apple.com/guide/mac-help/search-with-spotlight-mchlp1008/mac
https://talk.tidbits.com/t/do-you-use-it-spotlight-on-the-mac/23189?u=ace
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Searches for images within Photos and even more 
specific searches for locations in Maps, events and 
reminders, music, Mac App Store apps, fonts, 
movies, and videos rated only single-digit 
responses.

•Navigation: The second most popular Spotlight 
use was launching apps, with 64% of responses. 
Following that came opening folders, with 32% of 
responses. 25% of respondents also use Spotlight 
to access specific parts of System Settings rather 
than browse manually or search within the System 
Settings app. Spotlight has long been helpful for 
opening System Preferences panes in macOS 
versions before Ventura, but the tangled 
mishmash of System Settings may encourage 
more Spotlight-driven access.

•Utilities: Although they weren’t the most 
common Spotlight features, using it as a calculator 
(32%), for dictionary definitions (22%), and to 
make conversions (22%) all ranked in the top half 
of the responses. No one mentioned using 
Spotlight to track flights, but if you enter an airline 
code and flight number like AA123, you’ll get 
tracking information. This requires the Siri 
Suggestions category to be enabled.

•  

The takeaway? Most people use Spotlight for 
finding files and launching apps, with only 20–30% 
venturing into its more esoteric features. I see two 
paths forward.

First, if you have somehow missed out on all 
Spotlight can do, invoke it by clicking the 
magnifying glass in the menu bar (which can be 
turned off in older versions of macOS in System 
Preferences > Dock & Menu Bar > Spotlight) or 
pressing Command-Space (which you can change 
in System Settings > Keyboard > Keyboard 
Shortcuts > Spotlight). Then start typing and see 
what pops up in the results below. Explore all the 
possibilities—there will be a lot!

Second, if you find the Spotlight results 
overwhelming, turn off categories you’ll never use. 
Open System Settings > Siri & Spotlight to find 
them. In macOS 12 Monterey and earlier, they’re in 
System Preferences > Spotlight.
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Spotlight results can be hard to navigate if the 
results window is too small, forcing you to scroll. 
Many people don’t realize you can move and resize 
the Spotlight window, and it will remember its 
location and size for future searches. Try putting it 
at the top of your screen and expanding the results 
window to the bottomton see many more results at 
a glance.

You can also navigate the Spotlight results window 
with the arrow keys, and adding the Command key 
moves you between categories. Pressing Return 
opens the selected result. Apple lists a few other 
Spotlight keyboard shortcuts, but I’ve found others:

• Command by itself reveals the path to the selected 
file or folder.

• Command-B opens the search in your Web 
browser.

• Command-D opens the search term in the 
Dictionary app.

• Command-H opens Spotlight help.

• Command-L scrolls to the dictionary definition.

• Command-R or Command-Return reveals the 
selected file or folder in the Finder.

• Command-Y or Space bar previews the selection 
in Quick Look.

I suspect many people don’t use Spotlight as much 
as they could because the results appear in random 
order. Before macOS 10.11 El Capitan, Apple let 
users rearrange the order of the Spotlight results. 
Few people probably took advantage of that option, 
but it’s a shame Apple removed it. Now Spotlight 
puts the results in what it thinks is the most helpful 
order, but that means the order is different on every 
search, eliminating the benefit of familiarity. 
Turning off unused categories may reduce the 
randomness.

The most common complaint among poll 
respondents is that Spotlight can be unreliable, 
particularly for finding files and Mail messages. 
Although it may be only temporary, the fix is to 
rebuild the Spotlight database, which you do by 
opening System Settings > Siri & Spotlight > 
Spotlight Privacy, dragging your entire drive in 
from the Finder, and acknowledging what you’re 
about to do. (You can also add specific private 
folders here to ensure Spotlight never indexes 
them.) Wait a few minutes for Spotlight to delete 
the database, and then remove the drive from the 
Privacy list so Spotlight can reindex it. Be warned 
that the indexing process can take quite some time 
and cause significant CPU usage—you’ll see a 
bunch of mdworker processes in Activity Monitor, 
and there’s an Indexing progress bar at the top of 
the Spotlight results window while it works.

In some cases, Spotlight may seem unreliable 
because your search isn’t sufficiently specific. You 
can narrow your search results in four ways:

https://support.apple.com/guide/mac-help/spotlight-keyboard-shortcuts-mh26783/mac
https://support.apple.com/guide/mac-help/spotlight-keyboard-shortcuts-mh26783/mac
https://support.apple.com/guide/mac-help/spotlight-keyboard-shortcuts-mh26783/mac
https://support.apple.com/guide/mac-help/narrow-search-results-mh15155/mac
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•Metadata attributes: Anything that appears in the 
Info window for a file (select it in the Finder and 
choose File > Get Info) can be part of a search, 
such as modified date, kind, author, and much 
more—photos contain a lot of camera metadata.

• Item type: In the link above, Apple provides a 
long list of item types you can specify by adding 
kind:type to your search, including apps, 
contacts, folders, email, and much more.

•Keywords: Along with kind, Spotlight supports 
other keywords, including from, to, author, 
with, by, tag, title, name, keyword, and 
contains.

•Boolean searches: To make your search highly 
specific, use the Boolean operators AND, OR, and 
NOT, along with the minus sign (-), which means 
AND NOT.

I’d be surprised if many people took advantage of 
Spotlight’s options to narrow searches. Those who 
want more search power often resort to a third-
party app that provides a  graphical search 
interface, like HoudahSpot and Tembo. Another 
common approach is to sidestep the Spotlight 
database and search directly, which is slower but 
can be more reliable—EasyFind and Find Any File 
use this technique. The most common alternatives 
to searching for files with Spotlight include:

• Finder: Even though the Finder window search 
field (also accessible with Command-F) leverages 
the Spotlight database, many people prefer the 
Finder because it returns only files and folders.

• EasyFind

• Find Any File

• FoxTrot

• HoudahSpot

• NeoFinder

• Tembo

When it comes to Spotlight’s other popular feature, 
app launching, the list was essentially the same as 
for our Launchpad poll (see “Do You Use It? 
Launchpad Doesn’t Compete for Longtime Mac 
Users,” 11 August 2023). A few people even said 
that Alfred and LaunchBar were sufficient for most 
of their file-finding needs.

• The Dock, often holding the Applications folder or 
a folder of app aliases

• Alfred

• Butler

• iCollections

• LaunchBar

• Quicksilver

• Raycast

• SwitchGlass

In the end, it seems that Spotlight is earning its 
keep in the Mac world primarily for finding files 
and launching apps—the other features are frosting 
on top. That’s not to say that Apple should drop 
them, but I encourage you to turn off unnecessary 
categories. Also, Apple should bring back the 
feature that lets us rearrange categories and add the 
capability for Spotlight to detect and fix corruption 
automatically. We shouldn’t have to realize there’s a 
problem and reset the Spotlight database manually.

https://www.devontechnologies.com/apps/freeware
https://apps.tempel.org/FindAnyFile/
https://foxtrot-search.com/index.php
https://www.houdah.com/houdahSpot/?lang=en
https://www.cdfinder.de/
https://www.houdah.com/tembo/?lang=en
https://tidbits.com/2023/08/11/do-you-use-it-launchpad-doesnt-compete-for-longtime-mac-users/
https://tidbits.com/2023/08/11/do-you-use-it-launchpad-doesnt-compete-for-longtime-mac-users/
https://tidbits.com/2023/08/11/do-you-use-it-launchpad-doesnt-compete-for-longtime-mac-users/
https://www.alfredapp.com/
https://manytricks.com/butler/
https://naarakstudio.com/icollections/index.html
https://www.obdev.at/products/launchbar/index.html
https://qsapp.com/
https://www.raycast.com/
https://apps.apple.com/us/app/switchglass/id1498546559?mt=12
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I seldom write about beta software, particularly 
in great depth, but the utility and maturity of 
Arc, the new Chromium-based Web browser 

from The Browser Company, caused me to make an 
exception with “Arc Will Change the Way You 
Work on the Web” (1 May 2023). Nevertheless, 
recommending an app with a waitlist was 
awkward, even though TidBITS readers generously 
posted invitation codes in the article comments.

I’m pleased to note that The Browser Company has 
now released version 1.0 of Arc, making it a free 
download for everyone. Since I penned my 7000-
word opus, I have changed none of my core 
opinions about Arc—I still feel it is the most 
impactful app I’ve used on the Mac in years. I 
particularly appreciate being able to switch fluidly 
between the synced copies of Arc on my iMac and 
my MacBook Air, and I’ve become increasingly 
fond of Arc’s iPhone companion app because it 
contains pinned tabs to all the websites and pages 
on which I rely. (That said, the iPhone app still 
doesn’t display Favorites, an annoying and 
seemingly easily rectified lapse.)

My sole disappointment has been with the 
responsiveness of The Browser Company. None of 
my bug reports or suggestions were acknowledged 
(though some have been resolved), nor did my 
article generate any communication despite being 
more comprehensive than anything else ever 
written about Arc. (Yes, that’s authorial pique 
speaking; in contrast, I got a nice note from the 
developers of the WebKit-based Orion after just a 
brief mention in “A Roundup of Vertical Tab 
Support in Mac Web Browsers,” 5 June 2023.) Other 
TidBITS readers have noticed a similar lack of 
response to support questions. This silence feels at 
odds with how garrulous The Browser Company is 
on The Service Previously Known as Twitter (sadly) 
and YouTube, and the company’s seeming desire to 
encourage community (such as by creating a 
Credits page with over 34,000 names of beta testers. 

Perhaps the company will devote additional 
resources to customer support now that the beta 
period is over.

[Update: I’ve now heard from The Browser 
Company with an apology for the silence. I hadn’t 
internalized how many tens of thousands of users 
were beta testing, but as I suspected, the 
communication problem was too few staff for the 
volume of inquiries—thousands per day. The 
company is now focusing on scaling up. -Adam]

Arc’s developers have been far from idle in the 
months since my review. A significant release with 
new features and interface polish has arrived every 
Thursday like clockwork. Some of the more 
compelling changes include:

•Boosts: Although The Browser Company 
promotes Boosts heavily as a fun way to 
personalize any website, what keeps me from 
muttering “Waste CPU cycles drawing trendy 3D 
junk” under my breath is how Boosts are an 
accessibility win for those who need to make 
websites easier to read. Don’t like something 
about a site you regularly use? Create a Boost to 
change it. You can even use the Zap feature to 
remove entire elements from a page. Boosts get a 
section in the Library sidebar, and a Boost Gallery 
collects submissions from the community if you 
want to see what others have done. And no, I 
didn’t keep the Boost for the TidBITS site shown 
below. 

•Optional toolbar and Site Control Center: If Arc’s 
lack of a traditional wide toolbar at the top of the 

By Adam Engst

Innovative Web Browser Arc  
Reaches 1.0 Release

https://tidbits.com/2023/05/01/arc-will-change-the-way-you-work-on-the-web/
https://tidbits.com/2023/05/01/arc-will-change-the-way-you-work-on-the-web/
https://tidbits.com/2023/05/01/arc-will-change-the-way-you-work-on-the-web/
https://arc.net/
https://apps.apple.com/us/app/arc-mobile-companion/id1669785846
https://browser.kagi.com/
https://tidbits.com/2023/06/05/a-roundup-of-vertical-tab-support-in-mac-web-browsers/
https://tidbits.com/2023/06/05/a-roundup-of-vertical-tab-support-in-mac-web-browsers/
https://tidbits.com/2023/06/05/a-roundup-of-vertical-tab-support-in-mac-web-browsers/
https://twitter.com/browsercompany?lang=en
https://www.youtube.com/@TheBrowserCompany/videos
https://arc.net/credits
https://start.arc.net/release-notes
https://resources.arc.net/en/articles/6808613-boosts-customize-any-website
https://tidbits.com/search/waste%20cycles%20drawing
https://tidbits.com/search/waste%20cycles%20drawing
https://arc.net/boosts
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page is too jarring, you can now turn one on by 
choosing View > Show Toolbar. Or don’t—I prefer 
Arc’s small toolbar at the top of the sidebar, where 
you can access Boosts and other site-specific 
settings in the new Site Control Center. 

•Option-click for Split View: Arc’s Split View is 
great when you need to work back and forth 
between two tabs, such as when I’m copying an 
article I’ve written in Google Docs to a new post in 
WordPress. To make it even easier to create a Split 
View, you can now Option-click the second tab to 
create a Split View with it instantly. Now there’s 
no need to select both tabs, Control-click, and 
choose Open in Split View.

•Better multi-window behavior: Despite Split 
View, sometimes you need to open something in 
another window. In Arc, you can now drag any 
tab or favorite out of the window to create another 
window with its contents. It’s a full-fledged Arc 

window, although the sidebar is hidden by 
default. I love this feature, though I’m less happy 
about how unpinned tabs are now window-
specific and don’t sync across systems. Sometimes 
I want those synced and have to remember to pin 
them temporarily.

• Page translation: When you visit a page in 
another language, Arc automatically offers to 
translate it. I don’t need this often, but it’s handier 
than the Google Translate extension I had been 
using. 

•Multiple adblocker detection: Arc’s developers 
found that more than a third of people who 
import from Google Chrome have multiple 
adblockers enabled, which can radically hurt 
performance in any browser. Arc now detects that 
on import and prompts the user to pick one.

• Peek at any site: It’s now easier to open any link 
in a Peek over the current tab so you don’t lose 
your place—Shift-click a link. If you dislike this 
feature, turn it off in Arc > Settings > Links.
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•  

•Air Traffic Control: Although I’m a massive fan of 
Little Arc, the standalone window for links clicked 
from other apps, I’d prefer to open some links in a 
Space. The Air Traffic Control feature accessible in 
the Links settings lets you specify where links that 
match or contain specific strings open. 

• Paste New Tabs: You can now create a new tab 
with the contents of the clipboard by pressing 
Command-Option-V. If the clipboard contains a 
URL, Arc makes a new tab with it; if it contains 
text, the new tab loads with search results.

I still haven’t wrapped my head around Easels and 
Notes, so I can’t say any more about how they 
might be helpful. Nor do I ever peruse my archived 
tabs, media, or downloads—the Library sidebar 
remains terra incognito.

But I don’t care—Arc has become such a part of my 
work life that I actively dislike using other 
browsers now, not the least because I’m addicted to 
being able to press Command-Shift-C to copy the 
current page’s URL, something I do many times per 
day as I write and edit. I’ve built up hundreds of 
pinned tabs across my four Spaces, and I can 
quickly switch among the many sites I need to use 
without losing my place in any of them. And as I 
noted, I can easily do all that on either of my Macs 
or my iPhone because Arc lets me make a mental 
map of everything I have stored.

Arc may be overkill for those who use just a 
handful of tabs at a time, but if you spend much of 
your day working in websites, I recommend giving 
it a try. Arc is free to download and requires macOS 
12.1 Monterey or later. Remember, though, that it 
will take a few days to set up your Web mise en place 
before you really start cooking with fire.

https://resources.arc.net/en/articles/7670020-air-traffic-control-route-links-to-the-right-space-automatically
https://resources.arc.net/en/articles/6592969-easels-capture-create
https://resources.arc.net/en/articles/7020616-library-a-home-for-your-downloads-archived-tabs-easels-and-more
https://arc.net/
https://arc.net/

